MySQL Authentication plugin ‘caching_sha2_password’ cannot be loaded

问题:

当使用类似HidiSQL邓客户端连接MySQL的时候出现”Authentication plugin ‘caching_sha2_password’ cannot be loaded:找不到指定的模块”错误。

分析

分析发现,8.0改变了 身份验证插件 , 打开 my.ini (或者my.cofg) 可以看到变更了 5.7及其以前的方式: mysql_native_password,所以我们有两种途径解决

  1. 可以往你的连接工具、或者程序应用显示指定身份验证方式
  2. 回到过去,就是改为以前的版本方式

Continue reading MySQL Authentication plugin ‘caching_sha2_password’ cannot be loaded

javascript优秀插件收集

equalize.js 内容对齐插件

WOW.js 是一款效果炫酷的元素在页面滚动时展示CSS3动画的JS插件。默认wow.js使用animate.css作为动画库,但是你可以通过设置来使用你喜欢的动画库。

FitVids 是一个轻量级的,支持视频响应 即 嵌入流体宽度视频的jquery插件。

TinyMCE4 file_picker_callback

Code for TinyMCE:

Continue reading TinyMCE4 file_picker_callback

WordPress本地化、翻译

WordPress本地化,要用到的软件,PoEdit,它是一款.po(Portable Object)文件编辑器,,PoEdit常用来汉化各种程序,它内置于wxWidgets工具中,可以在所有它支持的平台上运行,如Unix下的GTK+以及Windows。PoEdit提供更方便的办法编辑目录,而不用通过启动VI文本编辑器,手动编辑。PoEdit是跨平台的开源软件,支持多国语言。

可悲的是:我今天访问他的官网(http://poedit.net/)好像被伟大的GD墙掉了。。

使用 poedit 翻译主题,必须有一个条件,即主题有语言包,可以在主题中看到:languages目录(比如:/public_html/wp-content/themes/twentyfourteen/languages/),然而有些邪教主题会放在lang目录,不过无所谓了,就一个名字而已,load_theme_textdomain 时指定他的目录。

如果要让主题支持语言包,那么你需要在你主题的 functions.php 文件添加下面的代码: Continue reading WordPress本地化、翻译

浏览器hack详细介绍

IE系列浏览器的hack大略如下:

 

1.‘9’:

Continue reading 浏览器hack详细介绍

视差滚动效果jQuery Stellar.js使用

什么为视差滚动效果看看下面这个网站http://www.sosglobal.eu/en/,是否觉得很熟悉呢?逛外国网站经常可以看到这个效果,接下来我们就来看看基于jQuery的Stellar插件实现视差滚动效果。Stellar.js是一款基于jQuery的插件,专业提供视差滚动效果30年,值得信赖。使用方法如下:
第一步,为元素对象添加 .stellar() 效果函数:

如果是对 ‘window’ 添加效果函数,可以简写成这样:

设定之后,该对象中的所有滚动背景或元素都会应用视差滚动效果。

Continue reading 视差滚动效果jQuery Stellar.js使用

视差滚动效果jQuery Stellar.js使用

什么为视差滚动效果看看下面这个网站http://www.sosglobal.eu/en/,是否觉得很熟悉呢?逛外国网站经常可以看到这个效果,接下来我们就来看看基于jQuery的Stellar插件实现视差滚动效果。

Stellar.js是一款基于jQuery的插件,专业提供视差滚动效果30年,值得信赖。使用方法如下:
第一步,为元素对象添加 .stellar() 效果函数:

如果是对 ‘window’ 添加效果函数,可以简写成这样:

设定之后,该对象中的所有滚动背景或元素都会应用视差滚动效果。 Continue reading 视差滚动效果jQuery Stellar.js使用

Jquery判断ie浏览器版本,用$.support替换$.browser判断

如果你也是Jquery最初的使用者,那么你一定经历过这样判断浏览器的时代:$.browser.msie && $.browser.version,你目前使用的组件里可能还有应用。但是Jquery1.3以后就不建议使用了,到jQuery 1.9之后就不复存在了。应该是因为到ie8以上的版本判断就有问题了…

只有另外想办法,使用$.support来判断浏览器!测试如下代码:

如果要检查ie浏览器,干脆直接使用 var isIE = /msie/.test(navigator.userAgent.toLowerCase());